آسیب پذیری بحرانی در محصولات جنکینز

به گزارش ایران 20 دانلود، جنکینز یک ابزار متن باز است که برای توسعه، استقرار و اتوماسیون پروژه ها مورد استفاده قرار می گیرد اما محصولاتش دچار یک ‫آسیب پذیری بحرانی شدند که می تواند منجر به تخریب حافظه و همچنین افشای اطلاعات محرمانه گردد.

آسیب پذیری بحرانی در محصولات جنکینز

به گزارش ایران 20 دانلود، جنکینز (Jenkins) یک ابزار متن باز است که برای توسعه، استقرار و اتوماسیون پروژه ها مورد استفاده قرار می گیرد. طبق اطلاعات مرکز ماهر (مدیریت امداد و هماهنگی رخدادهای رایانه ای) شرکت Jenkins در مورد یک ‫آسیب پذیری بحرانی در وب سرور Jetty که می تواند منجر به تخریب حافظه و همچنین افشای اطلاعات محرمانه گردد، هشدار داد. این آسیب پذیری بحرانی با شدت 9.4 شناخته می گردد و بر نرم افزار Eclipse Jetty ثر می گذارد.

جنکینز به وسیله یک رابط خط فرمان به نام Winstone از سرور Jetty استفاده می نماید و هنگام استفاده از هر یک از نصب نماینده ها یا بسته ها اجرا می گردد. این آسیب پذیری ممکن است به یک مهاجم بدون احتیاج به احراز هویت امکان دسترسی به سرآیندهای مربوط به پاسخ HTTP که ممکن است حاوی اطلاعات حساسی باشند، فراهم کند.

تخریب حافظه یا memory corruption این امکان را برای کلاینت فراهم می نماید که بین نشست ها حرکت کند و از این طریق به حساب های کاربری دیگر دسترسی داشته باشد، زیرا کوکی های احراز هویت از پاسخ یک کاربر به یک کاربر دیگر ارسال شده است و کاربر A می تواند در جلسه کاربر B پرش کند.

این آسیب پذیری که در ماه گذشته در Jetty 9.4.30.v20200611 منتشر شده بود، وصله شد. جنکینز این نقص را در برنامه های خود در Jenkins 2.243 و Jenkins LTS 2.235.5 وصله نموده است. به کاربران Jenkins توصیه می گردد به منظور کاهش نقض تخریب (corruption) در بافر، هر چه سریع تر نرم افزار خود را به آخرین نسخه به روزرسانی نمایند.

منبع: خبرگزاری ایسنا
انتشار: 23 مهر 1399 بروزرسانی: 23 مهر 1399 گردآورنده: iran20download.ir شناسه مطلب: 1179

به "آسیب پذیری بحرانی در محصولات جنکینز" امتیاز دهید

امتیاز دهید:

دیدگاه های مرتبط با "آسیب پذیری بحرانی در محصولات جنکینز"

* نظرتان را در مورد این مقاله با ما درمیان بگذارید